1

Closed

Unable to load iTuner 1.8.4627 Beta

description

When I try to load the iTunerSetup_1.8.4627B1.msi file on my Windows 7 machine, I get an error "This installation package is not supported by this processor type. Contact your product vendor". I previously had iTunerSetup_1.5.4475 running on this same machine. I then upgraded to iTunerSetup_1.7.4500 and had the same crash that everyone else was seeing. After completely uninstalling iTuner, I tried this Beta without success.
 
Marc
Closed May 16, 2014 at 1:23 PM by stevenmcohn

comments

stevenmcohn wrote Sep 7, 2012 at 10:02 PM

There is a 32bit installer on the download page as well as a 64bit install (the default). Do you have a 32bit machine but tried the 64bit installer?

wrote Sep 7, 2012 at 10:03 PM

wrote Sep 16, 2012 at 2:00 PM

wrote Feb 21, 2013 at 10:44 PM

wrote May 16, 2013 at 10:11 AM

wrote May 16, 2013 at 10:11 AM

wrote Jun 14, 2013 at 7:19 AM

wrote May 16, 2014 at 1:23 PM