Tried to build, installer ran, failed. Clean up?

Aug 8, 2012 at 12:42 AM

Hi Steven -

I downloaded your latest source code and tried to play with it.  When I hit F5 to build, some form of installer ran (much to my surprise).  However, the build/installer failed.

So... what have I done to my system, and what do I need to do to clean up?  There's no "iTuner" listed in the Add or Remove Programs, so I can't Uninstall from there...

Also - why can't I build?  Do I need to be enlisted in your TFS project to build?

Thanks for your help,


Aug 8, 2012 at 1:37 AM

Hi Joe,

F5 by default, performs an incremental build and then attempts to run the "default project" in the solution.  When you first load the solution, probably the first project is selected as the default project - this may be the installer?  So I'm guessing the iTuner installer is what you were seeing and it's that that probably failed - I'm guessing because you're not a local administrator perhaps?

Anyway, I recommend building the solution first by right-clicking the solution root node in the Solution Explorer and choosing "Build Solution".  If everything succeeds then manually run the installer in the output directory of that project.  If that succeeds then you're good to go!